CM Answers Guide: WordPress plugin Troubleshooting Procedure

The user guide has moved to a new location

This page is no longer maintained

If you are having some issues with the plugin behavior here are some initial assumption and several checks you should take before contacting support.

General WordPress plugin Troubleshooting Procedure

Initial Assumptions

The Pro plugin and the free plugin should not be activated together. If you have purchased the Pro plugin please deactivate the free edition before activating the Pro edition. You data will not be lost and will show up in the Pro plugin once activated.
Another assumption is that you are using the latest version of the plugin and are running the latest version of WordPress.

First Check – Server problems

Please check that the server info tab in the plugin settings to make sure all checks return the “OK” status:
WordPress plugin Troubleshooting Procedure

Second Check – JS errors

Please check your browser console (right click on the browser page and select Inspect Element, than click on the Console tab) to make sure it does not have any js errors. If it does make sure to fix them first. Please make sure you check this for both the Glossary index page and for both a page and a post page.

Third Check – Plugin conflict

Please deactivate other plugins you have and activate them one by one to check if one of them has a conflict with the CM plugin. If you find a plugin which conflicts you can always use Plugin Organizer to make sure they don’t run together.

Fourth Check – Theme conflict

Replace your theme with one of WordPress default themes to see if the problem arise from a conflict with your theme. This will help in understanding the source of the problem.

Detailed Troubleshooting

This section gives some information about some more specific problems.

JS in the footer

The plugin settings allow the JS to be loaded in the site’s footer (which is generally advised in the means of performance) but some of the themes don’t include the “wp_footer()” call and then the JS is not outputted to the page and tooltips don’t work. If the terms on your page are correctly marked but the tooltips don’t appear on hover and you have set the “Load scripts in the footer?” option – and they reappear if you uncheck this option – it means your theme doesn’t call “wp_footer()”.

Glossary Index Page looks different

If the Glossary Index Page doesn’t look as in documentation, but instead it’s blank or displays the list of the custom posts (with “glossary” type) it means either your theme or one of the plugins changed the default way of how the pages are working.

To know if the problem comes from the theme or from the plugins – first try to change the theme to one of the built-in WordPress themes. If the problem persists – that means it comes from one of the plugins. In this case try to call our support describing your problem with as much details as possible (also what you’ve already tried) we’d try to help.

On the other hand if the problem doesn’t exist in the other theme – it means you have to make some changes to the theme you’re using and ensure that:
– the template for the page is loaded and not for the archive of “glossary” posts
– the page template uses “the_content()” or “get_the_content()”

Glossary Index Page disappears when Jetpack by is activated

To solve the conflict between CM Tooltip Glossary and the Jetpack by you have to go to the Settings -> General Settings and uncheck the option Run the function outputting the Glossary Index Page only once” then save the settings. After doing so the Glossary Index Page should reappear.

Asian languages support

To make the plugin parse the content of the posts/pages written in the languages which don’t use the space to separate the words (like korean, japanese etc.) the option: “Highlight only space separated terms?” have to be unchecked.

Note: If this option is unchecked on the page using some western language e.g. English – then the glossary terms being part of the word would be marked. Example: Term “man” would be marked down in “Management”

Tooltip appears as “undefined”

Sometimes instead of the tooltip content from the Glossary Term the “undefined” shows up. Usually this means there are some JS errors on the page that need to be solved first.

For more information about this problem please go to this page.

Permalink Issues

Permalinks must be enabled in your WP in order for the plugin to work properly. Please go to Dashboard -> Settings -> Permalinks and enable the permalinks.

For more information about this problem please go to this page.

Characters in non-English languages that do not appear correctly

Usually this means that there are some problems with character encoding. For instance the DB tables are not using the utf-8 encoding.

For more information about this problem please go to this page.

Some Terms are not parsed

Make sure the Terms are defined in your Glossary, and that in the Plugin’s settings you haven’t set them not to be case-sensitive.

WordPress plugin Troubleshooting Procedure

Terms case-sensitive check

Glossary parsing is not working properly?

For detailed information about this problem please go to this page.

Related Articles link does not work (Pro Edition)

For detailed information about this problem please go to this page.

On the Glossary Index Page, the Terms are not sorted alphabetically

For detailed information about this problem please go to this page.

Term is defined in the Glossary BUT it is not showing highlighted on the page

For detailed information about this problem please go to this page.

Some element is missing regardless of being enabled by settings

For detailed information about this problem please go to this page.

Related articles are appearing in the widget area

When the options for the related articles are set it’s possible that they were generated for the post/page appearing in the widget area of the page. If the content of that post/page
will be displayed by “the_content()” function – the list of related articles may be displayed. In that case it’s worth checking for the widget settings if one of them allows not to run the filters.

Reference for more Troubleshooting Information